Results 1 to 15 of 15

Thread: 1989 CSX rough idle

  1. #1
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Post 1989 CSX rough idle

    I purchased this 1989 CSX new. It only has 19,000 miles on the car. The car developed a rough idle. It is a rough idle like is caused by a bad EGR valve. From the Haynes manual and EGR pictures from rock auto I can not find anything that looks like what is pictured on the VNT motor. Could I not be seeing something right. Or is the VNT motors EGR different? Is the intake manifold different? Could something else be causing the rough? I replaced the spark plug wires, distributor cap and rotor. That made no difference. The fuel pump and fuel filter were replaced two years ago. Any help would be greatly appreciated.

  2. #2
    turbo addict
    Join Date
    Dec 2005
    Location
    Lincoln, Nebraska
    Posts
    2,626

    Re: 1989 CSX rough idle

    I would go over the vacuum lines, looking for cracked hoses, loose connections. Spraying brake cleaner on the hoses while it's running can help find a vacuum leak. Perhaps take the vacuum line off the fuel pressure regulator and see if there's fuel in the line.

    There is no EGR on the VNT cars
    ďIf the people of the nation understood our banking and monetary system, I believe there would be a revolution before tomorrow morning.Ē -Henry Ford

  3. #3
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Thanks for the suggestions. Iíll give them a try. With no EGR valve, it explains why it looks different. Don

  4. #4
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,429

    Re: 1989 CSX rough idle

    How fresh is the gas?

    - - - Updated - - -

    ETA: I'm assuming that there are no codes?

  5. #5
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Sorry, I havenít got back on line sooner. I was out of town for the fourth. Iíve done the vacuum leak testing with the propane method. After about an hour I could not find anything. The gas should good. I only use non oxygenated 91 octane and have used some injector cleaner and heat to make sure there is no moisture. After vacuum testing I drove the car again. Once in a while the idle would settle down to normal (~950). As soon as you move the throttle, idle becomes rough (~950-1150). When I checked two weeks ago there were no codes. But checked after driving the car and I checked, this time there was a code. The code is 27 (Per the book. One of the injector control circuit output drivers does not respond to the control signal. check circuits.). Now what do I look at?
    Thanks in advance, once again, for your help. Don

  6. #6
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,429

    Re: 1989 CSX rough idle

    http://www.minimopar.net/fault/code27.html

    I would give the injector harness a good once over. It wouldn't surprise me at all if the wiring was bad. I would also check the 60 connector at the SBEC to ensure there is no corrosion, etc. If both of those look good, I would ohm out the individual wires to the injector section of the harness. There should be the green with black tracer Z1 wire brining power to everything and then the four wires which ground the individual injectors since it's sequential. If you have a scope and can look at the injector voltage, that would be a super fast way to look at it all.

  7. #7
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    It would be hard for me to think the harness is bad. Iíve had the car since new. Only 19,000 miles. There could be some wire corrosion on a connection other than the SBEC. I have two SBEC units. Iíve swapped them back and forth last year and the year before, when looking for another problem. So I donít think there is any pin corrosion. I can ohm out the wires. I donít have a scope.

  8. #8
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Some additional information on the problem. I can disconnect the battery to reset the SBEC unit. The car starts and idles prefect. Playing with the throttle everything is just fine. After doing this a few times the control unit must learn bad info from somewhere. The rough idle returns.

  9. #9
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Just some thoughts. If the engine runs preferably after wiping the codes, and then after a number of restarts it runs roughly, then one of the sensors providing input to the SBEC unit must be providing bad input. Does my reasoning make sense? If so, how many things provide input to the SBEC unit? I would appreciate an help you can give me.

  10. #10
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,429

    Re: 1989 CSX rough idle

    I would go through the connectors regardless, and then install that spare SBEC. If the spare computer does the same thing, you must have a real problem with the wiring, or perhaps an injector.

  11. #11
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Weíll continue looking.👍

  12. #12
    Garrett booster
    Join Date
    Jun 2007
    Location
    Waukesha, WI
    Posts
    76

    Re: 1989 CSX rough idle

    Code 27 keeps returning? Does it run well until it warms up, or runs well after it warms up and then sometime later runs rough?

  13. #13
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Iíll have to try it again. As best as I remember I was trying things all morning. So the car wasnít dead cold. When I cleared the code, I restarted it and ran it a couple of minutes each time. After restarting about five times the rough idle returned. I can try it again!

  14. #14
    Mitsu booster
    Join Date
    Sep 2020
    Location
    Wisconsin
    Posts
    17

    Re: 1989 CSX rough idle

    Ran the test again. Cleared the codes. Restarted a cold engine. First two minutes the engine idled fine. Throttle responded normal. After running four minutes the rough idle started to return. It got rougher as it continued to run. The code returned (27). Seems to me one site implied that for this code check the engine controller, injector wiring on #3 and #4, and maybe the injector was the problem. Is there a Noid light that can be used on this type of injector? Or is it just an ohm and volt test with a VOM?

  15. #15
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,429

    Re: 1989 CSX rough idle

    They make noid lights for them. I'm not sure what you're looking to spend tool wise, but you could get an oscilloscope to do the injector voltage for around $100. That should let you see if the injectors are mechanically functioning properly.

Similar Threads

  1. 94 Dakota Rough idle
    By Keito in forum Other vehicles
    Replies: 9
    Last Post: 09-19-2011, 01:27 PM
  2. still rough idle
    By 1bad89 in forum Maintenance & General Tech
    Replies: 12
    Last Post: 11-15-2009, 12:37 PM
  3. Rough Idle
    By stitus in forum "I need help!"
    Replies: 2
    Last Post: 07-07-2009, 06:10 PM
  4. Now what? rough idle to no start
    By Devsdaytona in forum "I need help!"
    Replies: 5
    Last Post: 03-04-2007, 02:19 AM
  5. very rough idle, need help!
    By daytonaturbo87 in forum "I need help!"
    Replies: 4
    Last Post: 11-16-2006, 02:57 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •