Page 5 of 5 FirstFirst 12345
Results 81 to 93 of 93

Thread: Falco Rosso SL#356

  1. #81
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    We have full instrumentation. Turned out to be a blown fuse even though my crappy meter said the fuse was Good yesterday. either way, it was an easy fix and allowed for some detailing in the car. I got her all cleaned out and all of the parts which still need to be installed are in the garage now.

    I adjusted the base idle as it wanted to constantly stall, and that smoothed things out nicely. My old actron meter came out to give a more exact number. Unfortunately, the stalling problem wasn't just a stalling problem. The car is cutting out and wanting to die some of the time. I'm strongly suspecting the hep cutting out right now, but we will see when I throw a spare in it after the car cools off a little.

    In the mean time, here are a couple of pics of how the car looks now. It has come a long way since I first bought it.

    Click image for larger version. 

Name:	20220808_175440.jpg 
Views:	22 
Size:	994.6 KB 
ID:	66035

    Click image for larger version. 

Name:	20220808_175502.jpg 
Views:	22 
Size:	2.00 MB 
ID:	66036

    Click image for larger version. 

Name:	20220808_175514.jpg 
Views:	21 
Size:	2.00 MB 
ID:	66037

  2. #82
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    The spare hep creates the same results. The car stumbles and wants to die while driving, but will easily catch itself when I give it some throttle. No codes, so I'm not really sure where to go with it. New coil perhaps?

  3. #83
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    I should add that we drove the car tonight after dark, and even in town the lights were incredible. The high beams had Joy and I both laughing.

  4. #84
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    It was indeed the calipers sucking in air past the seals. New big brakes with some hawk pads. They fit behind the Shelby wheels with room to spare. I'm very happy that this ordeal is past me. I did replace the LM today and it has run fine since, but I'm not ready to declare victory yet.

    Click image for larger version. 

Name:	20220811_170710.jpg 
Views:	15 
Size:	847.8 KB 
ID:	66038

  5. #85
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    Still some cutout issues on a longer drive last night. Enough that it will make me worry, but not bad enough to leave me stranded. Thought I would investigate grounds today. The direct battery Ground has seen better days, so that is being upgraded.

    Click image for larger version. 

Name:	20220813_110608.jpg 
Views:	18 
Size:	2.00 MB 
ID:	66039 Click image for larger version. 

Name:	20220813_110643.jpg 
Views:	18 
Size:	2.00 MB 
ID:	66040

  6. #86
    Supporting Member II Turbo Mopar Contributor minigts's Avatar
    Join Date
    Dec 2005
    Location
    Memphis, TN
    Posts
    6,874

    Re: Falco Rosso SL#356

    I don't think that's your issue, but probably ground related. I think you've seen this issue before and definitely a bad wire somewhere.


    Jon Trotter

    1985 Dodge Shelby Charger, Currently decommissioned
    1987 Shelby GLHS, #937
    1987 Shelby Lancer, #628

    Quote Originally Posted by Reeves View Post
    I can be ready. Please send pics of wife.
    _____DodgeZ add comments here______

  7. #87
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    Last time the solution ended up being install a new harness into the car. I need to find what is causing this rather than to go that route again. I'm going to test this, and do only one thing at a time. I think if I can get the voltage to stop the light flutter it has I will have found the problem.

  8. #88
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    Well, I pulled the horn relay with no effect. I did test the coolant temp sensor and it ohmed out just fine at about 7.5k with Temps in the 80s. I'll consider putting new terminals and housing on it under hood with a new sensor next.

    The only real clue I have is the code 22 which pops up each time I run the car. Even then I know that is most likely not what is causing the tach to die with the miss. I might throw a battery in there from another car, as that would be an easy thing to test. I didnhave a crazy battery related problem similar to the many years ago.

  9. #89
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    Here is a picture of the HEP with the new Deutsch connectors installed. I used some heat shrink tube to denote which one is the black connector.

    Click image for larger version. 

Name:	IMG_2114.jpg 
Views:	30 
Size:	2.26 MB 
ID:	66049

  10. #90
    Supporting Member II Turbo Mopar Contributor minigts's Avatar
    Join Date
    Dec 2005
    Location
    Memphis, TN
    Posts
    6,874

    Re: Falco Rosso SL#356

    Man that looks really nice!


    Jon Trotter

    1985 Dodge Shelby Charger, Currently decommissioned
    1987 Shelby GLHS, #937
    1987 Shelby Lancer, #628

    Quote Originally Posted by Reeves View Post
    I can be ready. Please send pics of wife.
    _____DodgeZ add comments here______

  11. #91
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    Thanks. It's easy to do, and really not expensive if you have the tool already.

  12. #92
    See me ride out of the sunset... Turbo Mopar Staff BadAssPerformance's Avatar
    Join Date
    Dec 2005
    Location
    Chicagoland!
    Posts
    27,567

    Re: Falco Rosso SL#356

    Quote Originally Posted by cordes View Post
    Last time the solution ended up being install a new harness into the car. I need to find what is causing this rather than to go that route again. I'm going to test this, and do only one thing at a time. I think if I can get the voltage to stop the light flutter it has I will have found the problem.
    in addition to grounds, check for damaged wires where they go thru the firewall ack to LM. years ago Tommy had an issue in a GLH and found broken wire there

    JT
    SDAC Director
    SDAC-Chicago President
    JOIN SDAC and your local Chapter TODAY! - SUPPORT the CLUB that supports YOUR HOBBY!
    87 Shelby Z - 10.50@141.66mph
    87 CSX #751 Clone - 12.88@102.88mph

    www.badassperformance.com
    Check out Turbo-Mopar Times!
    Submit your 1/4 mile times HERE!!

    Support SDAC! Join Today!
    "I'm not some pro athlete with a bajillion dollars, I'm just an every man"
    Note: The information and any images provided in this post are not for distribution outside this forum without the author's permission.

  13. #93
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    21,088

    Re: Falco Rosso SL#356

    I'll have another look in that area for sure. It looked Good, but I guess you never know. I think I'll know more when I start generating my own 8v signal tomorrow.

Page 5 of 5 FirstFirst 12345

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •