Results 1 to 17 of 17

Thread: I Need Help, I can`t figure it out

  1. #1
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    I Need Help, I can`t figure it out

    My 85 Z runs like S#@% now...I was bringing it home from my brothers house i got about a mile away and it died on me (Overheated) and would not start back up, so i pushed it into a parking lot and let it cool down a little. About 15 min`s later i got it to start but it ran like s*#@ and i got it home .It will start but it chugs like a train and when you push the gas it slowly revs up. I thought it might be a head gasket so i took out the plugs and looked in the cylinders with a little camera and there was no antifreeze in any. I changed the distributor pickup coil , distributor rotor ,TPS ,coil, Fpr , plugs & wires looked at the wastegate actuator (it`s broke and don`t have another one) put a new fuel pump & filter in it, I did notice that when i run it now ( I ran it for about 5 min`s ) the motor, and exhaust was not hot but the turbo was so hot i could not touch it. I was thinking maybe out of time , vacuum line or a clogged turbo ??Anyone have a idea what might be the problem ??
    Last edited by mrchuck; 03-28-2021 at 07:06 AM.

  2. #2
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,508

    Re: I Need Help, I can`t figure it out

    Any codes? I would check the cam timing. Running rough after overheating isn't a good sign though.

  3. #3
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    I haven`t checked for any codes yet. We just got done putting a new timing belt in it before to took it home.

  4. #4
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,508

    Re: I Need Help, I can`t figure it out

    Well, the cam timing sounds like it is the place to start.

  5. #5
    Supporting Member II Turbo Mopar Contributor jeff1234's Avatar
    Join Date
    Mar 2006
    Location
    Albany Wisconsin
    Posts
    830

    Re: I Need Help, I can`t figure it out

    Recently I had my intermediate shaft and oil pump gears wear out causing big changes in timing. It ran similar to your description. It couldn't hurt to pull the dist and examine the teeth for wear. My was very obvious, teeth worn to a sharp edge.
    The only substitute for cubic inches is cubic dollars, how fast can you afford to go?

  6. #6
    turbo addict
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    1,537

    Re: I Need Help, I can`t figure it out

    going out on a linb.. I'd do the easy check to see it the vacuum line on the fuel regulator smells like gas...maybe it's way way to lean ??
    it's to easy to cross of the list not to try..

  7. #7
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    The only codes i got was 12 & 55. Im moving on to checking the timing, post if i find anything else.

  8. #8
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    checked the timing ...it is good & no teeth missing. I could not get the O2 sensor out of the exhaust pipe to see if was a clog. I stuck my camera down the throttle body to see if the turbo was spinning and that was good . I pull the dist and examine the teeth for wear thats good . I also pulled the vacuum line on the fuel regulator and it did smells like gas but faintly.

  9. #9
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,508

    Re: I Need Help, I can`t figure it out

    Do you have a cat on the car? If the turbo is really hot, and the car is not running well, it could be a clogged cat. I'm still thinking it's something mechanical though, due to the situation. Have you tested the compression yet? That should be the real story with the HG.

  10. #10
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    Yes it does have a cat (you have to have one in the great state of PA) I was told by someone else to do a compression test . I have to get the tools to do that i don`t have it.

  11. #11
    turbo addict
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    1,537

    Re: I Need Help, I can`t figure it out

    asking how old is the head gasket

    and, if bad that cold be secondary to the overheating issue .. not the cause

    in the day it wasn't unusual for a motor that was only a few years old to need a head gasket the instant it overheated for some reason
    the o-e mopar gaskets don't like water .. they rot at the passages ..pretty quickly

  12. #12
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    I`m not sure how old the head gasket is , It has been on it since i bought it , I have never changed it figured it not leaking so why mess with it.

  13. #13
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    Well i figured i would pull the plugs & see if they were fowled and they all was. I cleaned them up and tried to start it and it ran the same. But i noticed when i was adjusting the distributor i heard clicking under the hood & the fuel pump kicking in. I noticed that the hall pick up wires was showing ( the coating is split) and when i started moving them i heard the clicking under the hood & the fuel pump kicking in. I put a new one in and it would not start, so i put the old one back in and set the wires from it up with a zip tie ( when i heard the click) and it fired right up and runs like nothing was ever wrong.

  14. #14
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,508

    Re: I Need Help, I can`t figure it out

    Well, hopefully it was just the HEP, but that's a very strange HEP failure.

  15. #15
    Garrett booster
    Join Date
    Dec 2016
    Location
    greenville,pa
    Posts
    66

    Re: I Need Help, I can`t figure it out

    I have to figure out why it overheated now and why the plugs are getting fowled up, but thanks for helping me figure it out.

  16. #16

    Re: I Need Help, I can`t figure it out

    Quote Originally Posted by mrchuck View Post
    Well i figured i would pull the plugs & see if they were fowled and they all was. I cleaned them up and tried to start it and it ran the same. But i noticed when i was adjusting the distributor i heard clicking under the hood & the fuel pump kicking in. I noticed that the hall pick up wires was showing ( the coating is split) and when i started moving them i heard the clicking under the hood & the fuel pump kicking in. I put a new one in and it would not start, so i put the old one back in and set the wires from it up with a zip tie ( when i heard the click) and it fired right up and runs like nothing was ever wrong.
    On the hall-effect, I think new ones can have a problem... Several years back I picked up a Shadow that was a no start... The prior owner had thrown the parts store at it trying to fix it. New timing belt, new hall-effect, new coil (included with the car.) Diagnosing through it, the new hall-effect was not working (on a long crank the tach should bump a little if the hall-effect is working.) New new hall-effect and the tach bumped, but didn't start. New coil and it did start.

    Anyway, I would do a compression test. One bad value, likely headgasket (or something related to that cylinder). All bad, likely the timing jumped (systemic issue...) All good, I would check ignition timing and fueling.

  17. #17
    turbo addict
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    1,537

    Re: I Need Help, I can`t figure it out

    um, thought occurs..a little late in the discussion,.... IT MIGHT have overheated , IF there's a big air bubble in the cylinder head that the water pump can't push out....

    been there done that .. new engine overheated badly within 3-5 miles...

Similar Threads

  1. Help me figure out which CV boots I need please
    By Five9dak in forum "I need help!"
    Replies: 3
    Last Post: 11-01-2010, 07:56 PM
  2. Bet you can't figure this one out.
    By GLHNSLHT2 in forum Electrical & Fuel System
    Replies: 11
    Last Post: 07-05-2009, 11:15 PM
  3. Try and figure this one out
    By shadowdude in forum Electrical & Fuel System
    Replies: 5
    Last Post: 08-04-2006, 07:59 PM
  4. Figure this one out....???
    By R/T in forum "I need help!"
    Replies: 30
    Last Post: 05-17-2006, 05:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •