Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Thread: Misfiring Under Load

  1. #1
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Misfiring Under Load

    My 2.5l turbo spirit is giving me issues. She misfires under any load.

    I checked the timing and itís good.
    changed the plugs wires...no difference.
    changed the coil, no difference.
    Changed cap and rotor, no difference.

    I swapped the hep to another one i had, but no idea if itís good.

    does this sound like a hep issue or is there something else Iím missing?

  2. #2
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Feb 2015
    Location
    toronto
    Posts
    1,402

    Re: Misfiring Under Load

    Any codes?
    Check grounds?
    Regards,
    Miles

    DD '87 Sundance T1, 12PSI, SLH with rear disks
    '87 CSX #432

  3. #3
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    12 and 55

    Which grounds should I check? Hep and Coil? Would the car even run with a bad ground on the coil??

    - - - Updated - - -

    Also I did disconnect the battery recently so the 12 code was expected.

  4. #4
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,409

    Re: Misfiring Under Load

    If it's the HEP, the tach should die when it misfires. It's generally something you can notice in my experience. A log would really help.

  5. #5
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    Quote Originally Posted by cordes View Post
    If it's the HEP, the tach should die when it misfires. It's generally something you can notice in my experience. A log would really help.
    Iíll try to log it tomorrow 👍🏻

    - - - Updated - - -

    Is there an electrical schematic somewhere?

  6. #6
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,409

    Re: Misfiring Under Load

    I've posted some in the past. Were you looking for anything in particular?

  7. #7
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    Quote Originally Posted by cordes View Post
    I've posted some in the past. Were you looking for anything in particular?
    Just the engine bay I guess. That would have ignition and all its grounds.

  8. #8
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Feb 2015
    Location
    toronto
    Posts
    1,402

    Re: Misfiring Under Load

    Quote Originally Posted by Fenderbass View Post
    Iíll try to log it tomorrow 

    - - - Updated - - -

    Is there an electrical schematic somewhere?
    What year is the car?
    Last edited by chromguy; 11-07-2020 at 10:27 PM.
    Regards,
    Miles

    DD '87 Sundance T1, 12PSI, SLH with rear disks
    '87 CSX #432

  9. #9
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,409

    Re: Misfiring Under Load

    Here is what I have up from a 90 P body.

    http://www.turbo-mopar.com/forums/ph...ry.php?cat=951

    I'll see if I have anything up from the other cars. For the most part, the under hood wiring doesn't change with the exception of the connectors and coil with regard to anything that should give drivability problems.

  10. #10
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    Quote Originally Posted by cordes View Post
    Here is what I have up from a 90 P body.

    http://www.turbo-mopar.com/forums/ph...ry.php?cat=951

    I'll see if I have anything up from the other cars. For the most part, the under hood wiring doesn't change with the exception of the connectors and coil with regard to anything that should give drivability problems.
    You are too legit! Thanks brother. Itís a 1989 but Iím sure these will work for me.

  11. #11
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,409

    Re: Misfiring Under Load

    This may be of help. It's unfortunately different from yours. It's for the 87 cars, but if you look up the 60 way connector on your car, it will just replace the power module and logic module in these diagrams.

    http://www.turbo-mopar.com/forums/ph...ry.php?cat=969

    Wow. the 90 60 way connector isn't listed on Minimopar. I never realized that until now.

  12. #12
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    checked the coil ground and the hep grounds. i have continuity

    chromguy i sent you the file.

  13. #13
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    video of problem

    https://youtu.be/cbkzI9JKDSk

  14. #14
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,409

    Re: Misfiring Under Load

    This might be of interest to you then.

    http://minimopar.net/ecu/smec-1988-t1.html

  15. #15
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    thanks cordes. i can't believe i didnt see that on minimopar. looks like i have some wiring to check tomorrow.

  16. #16
    Boost, it's what's for dinner... Turbo Mopar Staff Aries_Turbo's Avatar
    Join Date
    Dec 2005
    Location
    Warsaw, NY
    Posts
    8,499

    Re: Misfiring Under Load

    it sounds like the launch limiter where it is randomly dropping spark.

    I thought I disabled that in the cal.

    Does it do it as you go down the road?

    Brian

    Quote Originally Posted by turbovanman
    This one is easy, I have myself to blame, I rush things, don't pay attention to gauges when I should, change to much stuff at once then expect miracles, the list is endless.

  17. #17
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    Hey Brian. Ya it happens when Iím driving.

    Something interesting to note: I can make the misfire happen sooner in the rpm range by adjusting my fuel pressure up...any ideas what it could be?

  18. #18
    Supporting Member Turbo Mopar Contributor
    Join Date
    Oct 2018
    Location
    Minnesota
    Posts
    30

    Re: Misfiring Under Load

    Preignition/Detonation?

  19. #19
    Boost, it's what's for dinner... Turbo Mopar Staff Aries_Turbo's Avatar
    Join Date
    Dec 2005
    Location
    Warsaw, NY
    Posts
    8,499

    Re: Misfiring Under Load

    what is the air fuel ratio?

    did it start doing this all of a sudden?

    Brian

    Quote Originally Posted by turbovanman
    This one is easy, I have myself to blame, I rush things, don't pay attention to gauges when I should, change to much stuff at once then expect miracles, the list is endless.

  20. #20
    Garrett booster
    Join Date
    Jul 2020
    Location
    Goshen, New York
    Posts
    71

    Re: Misfiring Under Load

    Spark plugs set at .020-.025. Air/Fuel is between 11.5 and 12.5.

    I had changed the knock sensor (had a bad one and it gave me a check engine light; no check engine light now).

    Now I'm getting a fault code 25. Would a faulty AIS cause this issue?

Page 1 of 2 12 LastLast

Similar Threads

  1. Fuel issues, stumbling misfiring, 320hp Omni
    By BoostedDrummer in forum Electrical & Fuel System
    Replies: 44
    Last Post: 01-26-2015, 11:18 PM
  2. 86 Turbo Z misfiring, running poorly
    By Lee'sdaytona in forum "I need help!"
    Replies: 11
    Last Post: 08-05-2013, 09:14 PM
  3. Car NON stopped misfiring
    By Mysterio in forum "I need help!"
    Replies: 4
    Last Post: 02-05-2008, 05:34 PM
  4. My car feels like it is misfiring
    By VntEs in forum "I need help!"
    Replies: 14
    Last Post: 04-02-2007, 02:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •