Results 1 to 9 of 9

Thread: Turbo Caravan speedometer issue

  1. #1
    boostaholic
    Join Date
    Dec 2005
    Location
    Ewing, NJ
    Posts
    1,164

    Turbo Caravan speedometer issue

    Good morning!
    My 89 caravan with 225,000 miles on it apparently got tired of turning over the miles. The speedometer appeared to start working sporadically (bouncing around a little), until finally stopping altogether. Can anyone speak from experience on what the probable cause is? I'm thinking either speedometer cable broke, something on the speed distance sensor gear stripped out, or the gear in the transmission that drives the speed sensor gear is messed up (I assume highly unlikely).
    Hopefully it is not the cable either, as I have an extra SDS.
    Thanks,
    Lee

  2. #2
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,348

    Re: Turbo Caravan speedometer issue

    I've only ever had trouble with the cable when the speedometer behaves erratically.

  3. #3
    Supporting Member Turbo Mopar Contributor supercrackerbox's Avatar
    Join Date
    Dec 2005
    Location
    Firth, Nebraska
    Posts
    5,009

    Re: Turbo Caravan speedometer issue

    Does an '89 have a cable?

  4. #4
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,348

    Re: Turbo Caravan speedometer issue

    It should. My 90 does.

  5. #5
    Supporting Member Turbo Mopar Contributor supercrackerbox's Avatar
    Join Date
    Dec 2005
    Location
    Firth, Nebraska
    Posts
    5,009

    Re: Turbo Caravan speedometer issue

    Interesting. Daytonas eliminated the cable in '87, Omnis in '90 . . . and I can't remember if my '88 CSXT had a cable or not. Must just have been something they waited to change until doing a major facelift.

  6. #6
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,348

    Re: Turbo Caravan speedometer issue

    Quote Originally Posted by supercrackerbox View Post
    Interesting. Daytonas eliminated the cable in '87, Omnis in '90 . . . and I can't remember if my '88 CSXT had a cable or not. Must just have been something they waited to change until doing a major facelift.
    P body cars were cable speedos until 90.

  7. #7
    boostaholic
    Join Date
    Dec 2005
    Location
    Ewing, NJ
    Posts
    1,164

    Re: Turbo Caravan speedometer issue

    sooo....are we thinking the plastic gear stripped out or the cable broke?

  8. #8
    Supporting Member Turbo Mopar Contributor GLHS60's Avatar
    Join Date
    Dec 2005
    Location
    Sherwood Park Alberta, Canada
    Posts
    1,417

    Re: Turbo Caravan speedometer issue

    Scientific method of determining if it's the gear:


    Thanks
    Randy

    https://wheeldecide.com/wheels/chanc...ecision-maker/


    There is no logical reason to call an Engine a motor.

    Randy Hicks
    86 GLHS60
    86 GLHS 373 : SOLD, but never forgotten
    89 Turbo Minivan
    83 Turbo Rampage : SOLD
    Edmonton,Alberta,Canada

  9. #9
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,348

    Re: Turbo Caravan speedometer issue

    Quote Originally Posted by Lee'sdaytona View Post
    sooo....are we thinking the plastic gear stripped out or the cable broke?
    I would check the cable first, then pull the gear if it looks OK.

Similar Threads

  1. 2010 Caravan electrical issue
    By chromguy in forum Other vehicles
    Replies: 2
    Last Post: 02-16-2019, 02:39 PM
  2. 1989 Caravan radio back lighting issue
    By firehawk618 in forum Electrical & Fuel System
    Replies: 5
    Last Post: 05-18-2018, 06:25 PM
  3. Speedometer issue
    By Johnny in forum Electrical & Fuel System
    Replies: 8
    Last Post: 08-27-2013, 07:36 AM
  4. Caravan Hatch strut issue
    By Lee'sdaytona in forum "I need help!"
    Replies: 4
    Last Post: 06-18-2011, 08:01 PM
  5. Think I found my neon speedometer issue
    By jory in forum Dodge Motors - Heritage to Current
    Replies: 5
    Last Post: 06-24-2009, 03:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •