Results 1 to 9 of 9

Thread: Did I kill my Knock Sensor Circuit?

  1. #1
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,410

    Did I kill my Knock Sensor Circuit?

    This is regarding the SMEC in my lancer. I was lazy and grabbed a bK/green tracer wire and spliced in the 0-1v NB output from my WBO2 controller to feed the computer the signal. Only problem was that there are two black with green tracer wires in that area. I grabbed the one for the knock sensor instead of the O2 sensor signal. Will feeding a DC 0-1V signal to the knock sensor signal wire destroy that portion of the board? I'm getting very little knock voltage out of the computer now. It is .02V unless I really let a 1/2" drive extension rattle the intake. There were a couple times I did get some knock voltage when in boost, but it really didn't pull timing.

    I did check the continuity from the knock sensor to pin #2 on the SMEC and it is great.

    On the up side, the car is making more power at the same boost. The clutch is now slipping after my upgrades including a ported head and exhaust manifold, TII intake, and S60 IC. Ups and downs here I guess...

  2. #2
    Supporting Member II Turbo Mopar Contributor tryingbe's Avatar
    Join Date
    Dec 2005
    Location
    Mesa, AZ
    Posts
    7,274

    Re: Did I kill my Knock Sensor Circuit?

    Doubt it.
    Tailgate at your own risk.

  3. #3
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,410

    Re: Did I kill my Knock Sensor Circuit?

    Quote Originally Posted by tryingbe View Post
    Doubt it.
    I would be thrilled if that were the case. I'm just worried that a circuit which is designed to take what I imagine would be AC millivolts might not like 1V DC. If it is working right, I'm getting no knock at all, not even any noise so I guess my knock sensor could be faulty too. Good times.

  4. #4
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Feb 2015
    Location
    toronto
    Posts
    1,404

    Re: Did I kill my Knock Sensor Circuit?

    Nah will not hurt it at all
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	85_86_87_detonation_diag.gif 
Views:	28 
Size:	74.7 KB 
ID:	65112  
    Regards,
    Miles

    DD '87 Sundance T1, 12PSI, SLH with rear disks
    '87 CSX #432

  5. #5
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,410

    Re: Did I kill my Knock Sensor Circuit?

    Quote Originally Posted by chromguy View Post
    Nah will not hurt it at all
    Thank the Lord. With the WBO2, and MPSciLink hooked up to this tablet, it's time for some tuning. I'm quite lean right now, so I'll need to check out the physical fuel system before I get too carried away with the cal side. The ported head bits and S60 IC certainly seem to be doing the job though.

    - - - Updated - - -

    ETA: Where did you come up with all of these schematics?

  6. #6
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Feb 2015
    Location
    toronto
    Posts
    1,404

    Re: Did I kill my Knock Sensor Circuit?

    Quote Originally Posted by cordes View Post

    ETA: Where did you come up with all of these schematics?
    They are from my hard drive.....LOL
    Please read this!
    http://www.turbo-2.com/pdf/adv-turbo-theory.pdf
    Regards,
    Miles

    DD '87 Sundance T1, 12PSI, SLH with rear disks
    '87 CSX #432

  7. #7
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,410

    Re: Did I kill my Knock Sensor Circuit?

    Thanks, Miles!

  8. #8
    turbo addict
    Join Date
    Dec 2005
    Location
    Spokane, Wa
    Posts
    9,014

    Re: Did I kill my Knock Sensor Circuit?

    When I went ported head, big plenum 2 piece, and tube header I had to add 50% more fuel at idle rpm. And about 25-30 everywhere else.

  9. #9
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    20,410

    Re: Did I kill my Knock Sensor Circuit?

    Quote Originally Posted by GLHNSLHT2 View Post
    When I went ported head, big plenum 2 piece, and tube header I had to add 50% more fuel at idle rpm. And about 25-30 everywhere else.
    I can tell this thing is going to need a lot more fuel. I think the cal has enough leeway to get it right at idle, but I bet I'm using all the adaptives can give. The clutch now slips at 3-4PSI, so I need to do that before any real tuning can begin.

Similar Threads

  1. Electronics T3 knock sensor and knock sensor harness
    By 168glhs1986 in forum Parts Wanted
    Replies: 2
    Last Post: 03-29-2014, 05:49 PM
  2. Replies: 22
    Last Post: 06-26-2013, 07:11 PM
  3. Replies: 3
    Last Post: 05-05-2012, 09:12 AM
  4. LC1 running ox sensor circuit-pig lean???
    By turbovanmanČ in forum EFI Tuning
    Replies: 18
    Last Post: 04-16-2011, 02:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •