Results 1 to 3 of 3

Thread: 89 Daytona not charging

  1. #1
    Mitsu booster
    Join Date
    Apr 2016
    Location
    Nevada
    Posts
    11

    89 Daytona not charging

    I replaced the alternator , I have battery voltage at the main terminal , key on voltage at the field , fuse links seem good (and iirc , wouldn't have field voltage if this was the problem anyway?) also no codes . 89 shelby z , can anyone point me in the direction of troubleshooting wiring and smec , please ?

  2. #2
    Hybrid booster
    Join Date
    Sep 2011
    Location
    Maryland
    Posts
    326

    Re: 89 Daytona not charging

    Have you tried full fielding the alternator momentarily to see what voltage is at the battery?
    Check the wiring for the regulator from the computer to the alternator.

    If you have very high battery voltage after full fielding, the voltage regulator inside the SMEC is to blame. At that point you would have to convert to an external regulator, or repair/ replace the power module.

  3. #3
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,742

    Re: 89 Daytona not charging


Similar Threads

  1. Alt. not charging
    By iangoround in forum Electrical & Fuel System
    Replies: 35
    Last Post: 10-25-2013, 09:58 AM
  2. Charging issue
    By AzShadow in forum Electrical & Fuel System
    Replies: 2
    Last Post: 09-06-2013, 10:14 AM
  3. Alt not charging
    By prepared in forum Electrical & Fuel System
    Replies: 5
    Last Post: 07-15-2010, 01:12 PM
  4. Car not charging. HELP!!!!!!!!!!!!!!!!
    By shelbyplaya in forum "I need help!"
    Replies: 10
    Last Post: 09-25-2008, 02:27 PM
  5. not charging
    By 2slowforu in forum "I need help!"
    Replies: 1
    Last Post: 10-30-2006, 09:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •