Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Thread: mpscilink 2.7 setup

  1. #1
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    mpscilink 2.7 setup

    Hey guys. Got my assembled mpscilink.

    Im trying to make an aggro. of my current challenges questions and steps i've taken.

    1. Plugged it in at computer(win 10pro 64) via provided usb cable
    2. Downloaded mpscandroid, setup bluetooth, save and sent lst files to mpscilink via scandroid bluetooth..... will the nextion display power up via usb or does it need 12v? needs 12v
    3. Downloaded latest ardrino drivers.

    so currently im trying to get mptune to communicate with the mpscilink. to update the unit

    current issue MpTune is reading an ecu port on com1 and sees the mpsclink on com3 (under setup com port mpscilink is in the mpscilink section)
    the bottom left corner stays as 'serial port settings com1' and the mpscilink tab is inactive....(none of the buttons work) what am i missing here? (i deleted com port 1 and it switched to com3 in the status window, did not communicate with mpsclink...)


    hmm.. *I was missing libusb0.dll to flash the arduino. I went and downloaded the .zip version of the Arduino ide program and found the file and pasted it into /program files /mptune (not documents/mptune)

    (dont have fb or hangouts...)
    Last edited by Sloride; 12-18-2018 at 10:48 PM.

  2. #2
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Feb 2015
    Location
    toronto
    Posts
    1,007

    Re: mpscilink 2.7 setup

    Wayne is the best to answer these question. I will give it a go,
    The MPSciLink board will need 12V to power the display and operate the analog reference.
    Last edited by chromguy; 12-18-2018 at 11:36 AM.
    Regards,
    Miles

    DD '87 Sundance T1, 12PSI, SLH with rear disks
    '87 CSX #432

  3. #3
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Jun 2006
    Location
    Spearfish SD
    Posts
    1,941

    Re: mpscilink 2.7 setup

    Quote Originally Posted by Sloride View Post
    Hey guys. Got my assembled mpscilink.

    Im trying to make an aggro. of my current challenges questions and steps i've taken.

    1. Plugged it in at computer(win 10pro 64) via provided usb cable
    2. Downloaded mpscandroid, setup bluetooth, save and sent lst files to mpscilink via scandroid bluetooth..... will the nextion display power up via usb or does it need 12v?
    3. Downloaded latest ardrino drivers.

    so currently im trying to get mptune to communicate with the mpscilink. to update the unit

    current issue MpTune is reading an ecu port on com1 and sees the mpsclink on com3 (under setup com port mpscilink is in the mpscilink section)
    the bottom left corner stays as 'serial port settings com1' and the mpscilink tab is inactive....(none of the buttons work) what am i missing here? (i deleted com port 1 and it switched to com3 in the status window, did not communicate with mpsclink...)


    hmm..

    (dont have fb or hangouts...)
    plug in the arduino to the pc, start mptune, exit and post up the mpt2coms.txt file in your documents/mptune directory.
    89 Voyager LE, 2.5T2 - rest in peace
    87 Charger Shelby T2 (2.4 conversion in process)

  4. #4
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    Re: mpscilink 2.7 setup

    -Comport analysis for mptune version 2.0.6.8
    -Locating ports on computer-
    name:Communications Port (COM1) deviceid:ACPI\PNP0501\1
    name:Arduino Mega 2560 (COM3) deviceid:USB\VID_2341&PID_0042\55736323339351D002A 0
    number of ftdi devices found - 0
    default com port set to:COM1





    this is only with the ardiuno plugged in. (no 12 to mpscilink board)
    i do have the telegram app

  5. #5
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Jun 2006
    Location
    Spearfish SD
    Posts
    1,941

    Re: mpscilink 2.7 setup

    so it located the arduino on com port 3 so in the com port setting screen you should be able to pick that com port for the mpscilink and also set the baud rate to 115200.
    89 Voyager LE, 2.5T2 - rest in peace
    87 Charger Shelby T2 (2.4 conversion in process)

  6. #6
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    Re: mpscilink 2.7 setup

    ne other port settings?

    it shows up in com port setting, but doesn't respond to the mpscilink tab. and the status bar still says com1 ecu port

  7. #7
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    Sorry about this, just seeing this now.

    MPTune looks correct since it recognizes as Arduino Mega, but when you go to windows Device Manager, under Ports, does it list Arduino Mega under Com3? It sounds like that is the case.
    If not, you may have a driver issue. I've found it may not load all the drivers if you download arduino IDE as a Win10 app.

    You will need to change the com port to com3 for the arduino under tools/com port/settings



    The display is not powered when the arduino gets powered through the USB1 port. The display is only powered through the 12v supply but using a seperate DC-DC to drop to 5v.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  8. #8
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    If you need more assistance I may be able to help later from work.

    Do you remember if your arduino had a white bottom, or was it blue? From the sound of it should be white.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  9. #9
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    Re: mpscilink 2.7 setup

    it is a white bottom with a blue O.

    It shows in device manager under ports as aduirno mega 2560 com3....
    i did install the 'win 10 app' ill uninstall an try the other driver program (it also shows in the usbview program and responds in the adurino app.


    the tool com port section you mentioned, is that through the adurino app?

  10. #10
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    Quote Originally Posted by Sloride View Post
    it is a white bottom with a blue O.

    It shows in device manager under ports as aduirno mega 2560 com3....
    i did install the 'win 10 app' ill uninstall an try the other driver program (it also shows in the usbview program and responds in the adurino app)
    So when you change the mptune com port to Com3, and try to flash the mpscilink, do you get an error?

    Flashing the mpsclink is the only thing you need to do in mptune at this point.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  11. #11
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    Re: mpscilink 2.7 setup

    yeah get a dll error
    it is
    libusb0.dll
    Last edited by Sloride; 12-18-2018 at 10:29 PM.

  12. #12
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Jun 2006
    Location
    Spearfish SD
    Posts
    1,941

    Re: mpscilink 2.7 setup

    Quote Originally Posted by wowzer View Post
    so it located the arduino on com port 3 so in the com port setting screen you should be able to pick that com port for the mpscilink and also set the baud rate to 115200.
    forget what i said!!!! that com port screen is only for the mpscilink bluetooth setup. for the arduino flash the program will automatically try to find the correct com port and then run the avrdude.exe program which has all the other settings (e.g. baudrate) hardcoded. long day :-(

    - - - Updated - - -

    Quote Originally Posted by Sloride View Post
    yeah get a dll error
    post up the error. it probably has to do with avrdude.exe. i think someone else was having this problem also wayne. (ray grosse on facebook.)
    89 Voyager LE, 2.5T2 - rest in peace
    87 Charger Shelby T2 (2.4 conversion in process)

  13. #13
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    To fix the .dll errors:

    If you have an error regarding a missing .dll file.
    You can do a file seach using windows file explorer to find it.
    The .dll is probably in the Arduino folder- copy and paste it to the MPTUNE folder. This allows the flashing of the MPSCILINK through MPTUNE.

    Let me know how it goes after that! Hopefully that works. It will at least get you furthervthan that error.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  14. #14
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    Re: mpscilink 2.7 setup

    okay.
    so i copied the libusb0.dll into the /program files/mptune main directory. (not the documents/mptune)

    and she worked!!


    I updated first post... now its on to 12v, playing with the screen, finding a smaller micro sd card (im assuming class 10) then wiring it to the car and repeat.


    Thanks guys!!!


    ....so mptune com port for mpscilink is reading the bluetooth rate?
    Last edited by Sloride; 12-18-2018 at 11:09 PM.

  15. #15
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    Quote Originally Posted by Sloride View Post
    okay.
    so i copied the libusb0.dll into the /program files/mptune main directory. (not the documents/mptune)

    and she worked!!


    I updated first post... now its on to 12v, playing with the screen, finding a smaller micro sd card (im assuming class 10) then wiring it to the car and repeat.


    Thanks guys!!!


    ....so mptune com port for mpscilink is reading the bluetooth rate?
    You can power the device with 12v on the bench to help get things set up.
    Once it gets powered it takes a few seconds, then you should see the display blink (refresh) and you should see a Bluetooth icon and an SD card icon (if a card is available in the slot).
    You dont need a fancy, or very large card. Morris recommended a 2GB Sandisk card. I have used a 16GB Sandisk SDXC card when i had corrupted a card i was previously using and needed one quickly.

    Since you have reflashed the arduino, you might need to go through everything. I dont think it will display my test log layout, but you could try (if you are a SMEC T1).

    Since you have it powered with 12v, you have noticed the BT module flashing, startup mpscandroid on your device, and try to pair bluetooth (from the main menu).
    It may take a couple attempts to connect. The passcode is: 1234
    Once connected the full buttons on the main mpscandroid page are enabled.

    For your display you will need a battery for the real time clock. It is a CR1220 iirc. Set the time/date using the nextion hmi under Clock. You can set the display brightness under Setup. You csn set a brightness for day and night. (It wont switch automatically yet, but may be able to have Morris program that in a later update.)

    BTW, without a SD card, you can still log with your android, and once you havea successful log session, you can use the Monitor selection on the HMI, for realtime data stream without logging. You can not log on android and on the hmi at the same time.


    Hope this helps.
    If you have more questions or issues, just let me know.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  16. #16
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    Oh, meant to ask if you already have a layout created in mpscandroid? Tip: once you configure an individual gauge type (verticle, left, right, analog, digital, bit) save it as default for gauge type. This will save having to change fonts, colors, size, etc for all the following gauges you add of that type.

    Also, since the two programs are designed to work somewhat similarly, you may alternatively send your existing MPScan layout ( the .mpc file) to your android.
    You'll have to locate it in /android/data/mpscilink/files/mpc folder. Then you may be able to simply edit the gauges for size, shape, etc to fit your screen size.

    Analog inputs take a bit more setup, so we can go over that later, if the videos dont answer those questions.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  17. #17
    Garrett booster
    Join Date
    Feb 2006
    Location
    Ontario
    Posts
    201

    Re: mpscilink 2.7 setup

    Yeah, ive been fiddling with scandroid. i created a little layout....

    When i get to logging, does the app only log what i am displaying or does it log everything from the ecu?

  18. #18
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Jun 2006
    Location
    Spearfish SD
    Posts
    1,941

    Re: mpscilink 2.7 setup

    Quote Originally Posted by Sloride View Post
    okay.
    so i copied the libusb0.dll into the /program files/mptune main directory. (not the documents/mptune)

    and she worked!!


    I updated first post... now its on to 12v, playing with the screen, finding a smaller micro sd card (im assuming class 10) then wiring it to the car and repeat.


    Thanks guys!!!


    ....so mptune com port for mpscilink is reading the bluetooth rate?
    send me the libusb0.dll you got to work so i can compare it to mine. windows is suppose to install this driver automatically when you insert the usb cable. it is also part of the regular arduino ide package. i'll start including it in the autoupdate part of the program.

    the mpscilink com port setting in mptune under settings/com port is if you happen to have a bluetooth on your pc that you could use to connect to the mpscilink device. i orginally used that method to test the mpscilink device before i got the android stuff going. it probably should not be used and i'll most likely disable the menus in future releases of mptune/mpscan.
    89 Voyager LE, 2.5T2 - rest in peace
    87 Charger Shelby T2 (2.4 conversion in process)

  19. #19
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    Quote Originally Posted by Sloride View Post
    Yeah, ive been fiddling with scandroid. i created a little layout....

    When i get to logging, does the app only log what i am displaying or does it log everything from the ecu?
    It will only log/display the ecu gauges that you select and setup in your layout. (.mpc file)
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  20. #20
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,409

    Re: mpscilink 2.7 setup

    This might be a bit helpful for wiring connections. If someone has the time to make a nice drawing based on this, please make shareable. I could scan a top panel from an enclosure if you want exact dimensions for scaling.
    MPSciLink v2.7 shown.
    v2.5 has no +12v Batt terminal
    v2.0 has no +12v Batt terminal, analog input placement is different (however still numbered A1-A4 GGGG left to right), and has no reset button
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

Page 1 of 2 12 LastLast

Similar Threads

  1. MPSciLink
    By wowzer in forum EFI Tuning
    Replies: 297
    Last Post: 07-04-2019, 12:21 PM
  2. MPSciLink starting a Group3 Pre-Order
    By wheming in forum EFI Tuning
    Replies: 258
    Last Post: 06-04-2019, 01:05 AM
  3. Replies: 9
    Last Post: 11-13-2018, 12:51 AM
  4. MPSciLink device pre-order
    By wheming in forum EFI Tuning
    Replies: 336
    Last Post: 04-24-2018, 12:18 PM
  5. The best computer setup for my engine setup..
    By 89ShelbyGuy in forum Electrical & Fuel System
    Replies: 33
    Last Post: 06-10-2008, 05:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •