Results 1 to 14 of 14

Thread: Stock Boost Control Not Working

  1. #1
    Garrett booster
    Join Date
    Sep 2009
    Location
    Central, NJ
    Posts
    211

    Stock Boost Control Not Working

    After running MBC's for years I thought I'd go back to stock boost control for simplicity sake, however I have an overboost condition.

    I am running a 2.5 Mopar Performance SBEC. All vacuum lines are new, and I am running the requisite restrictor in wastegate line.

    I assume that the fact the rest to the setup is not stock - +1mm bigger valves, Super 60 turbo, 3" s/c & d/p - impacts the computer's ability to control boost?

    Just wanted to confirm/get general consensus before I start chasing an issue that isn't.

    Thanks.

  2. #2
    Moderator Turbo Mopar Staff Force Fed Mopar's Avatar
    Join Date
    Dec 2005
    Location
    Greenville/Spartanburg SC area
    Posts
    7,504

    Re: Stock Boost Control Not Working

    Or your solenoid isn't working...
    Rob M.
    '89 Turbo GTC
    2.5 TIII swap is here!

    Project LookOwt
    '91 Daytona ES, 61k original miles, Rick Lozier's old 3.0 nitrous car
    Back to basics, then the mods go back on....

  3. #3
    turbo addict
    Join Date
    Dec 2005
    Location
    Mesa, AZ
    Posts
    7,027

    Re: Stock Boost Control Not Working

    Too much boost or not enough boost?

  4. #4
    Garrett booster
    Join Date
    Sep 2009
    Location
    Central, NJ
    Posts
    211

    Re: Stock Boost Control Not Working

    I should have described the overboost condition better. Itís holding the boost at around 15-16 psi.

    - - - Updated - - -

    Too much. I believe the MP cal should be good for 11psi.

  5. #5
    Hybrid booster
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    935

    Re: Stock Boost Control Not Working

    yeah should be 11-12

    have you double checked you routed the correct lines to the correct ports on the solenoid?

  6. #6
    turbo addict
    Join Date
    Dec 2005
    Location
    Mesa, AZ
    Posts
    7,027

    Re: Stock Boost Control Not Working

    Quote Originally Posted by Oggie Fisher View Post
    I should have described the overboost condition better. Itís holding the boost at around 15-16 psi.

    - - - Updated - - -

    Too much. I believe the MP cal should be good for 11psi.
    Sounds like time to upgrade to a 3 bar map, bigger injectors, and a custom calibration.

  7. #7
    Garrett booster
    Join Date
    Sep 2009
    Location
    Central, NJ
    Posts
    211

    Re: Stock Boost Control Not Working

    @tryingbe - True. But am I resistant to change and was just looking for reliability right now.

  8. #8
    turbo addict
    Join Date
    Dec 2005
    Location
    Mesa, AZ
    Posts
    7,027

    Re: Stock Boost Control Not Working

    Put the MBC back on.

    I was never able to get the stock boost control working after putting in aftermarket parts.

    Different compressor wheel, different actuator, bigger swingvalve and exhaust etc all affect boost numbers.

  9. #9
    Garrett booster
    Join Date
    Sep 2009
    Location
    Central, NJ
    Posts
    211

    Re: Stock Boost Control Not Working

    Thx tryingbe. I will double check my lines, but your experience was the confirmation that I was looking for to go back to MBC.

  10. #10
    Hybrid booster
    Join Date
    Oct 2015
    Location
    Jacksonville
    Posts
    330

    Re: Stock Boost Control Not Working

    ya man. make/buy a Gvalve. set it where you want. leave it. more reliable stuff you could never ask for.

  11. #11
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,262

    Re: Stock Boost Control Not Working

    Quote Originally Posted by Force Fed Mopar View Post
    Or your solenoid isn't working...
    Or he could have the TII routing vs. the TI routing that the 2.5 cal should come with. He could be making all the boost a stock small can WG can make?

  12. #12
    Garrett booster
    Join Date
    Sep 2009
    Location
    Central, NJ
    Posts
    211

    Re: Stock Boost Control Not Working

    None of the factory vaccume lines remain. Everything is fresh - silicone lines and aluminum distribution block. Car was originally a VNT car. Plumbed the wastegate line per the 1990 T1 diagram. Just for giggles, before l reinstall the MBC Iíll pull the wastegate line and see what happens.
    Last edited by Oggie Fisher; 09-17-2018 at 09:58 AM.

  13. #13
    Supporting Member II Turbo Mopar Contributor 83scamp's Avatar
    Join Date
    Mar 2013
    Location
    Columbia City, Indiana
    Posts
    1,222

    Re: Stock Boost Control Not Working

    Quote Originally Posted by Oggie Fisher View Post
    None of the factory vaccume lines remain. Everything is fresh - silicone lines and aluminum distribution block. Car was originally a VNT car. Plumbed the wastegate line per the 1990 T1 diagram. Just for giggles, before l reinstall the MBC Iíll pull the wastegate line and see what happens.
    You don't want to pull the waste gate line, you want to hook it up direct from turbo outlet to waste gate can. If it's a stock style can, should give you about 7-8 psi boost. Are you sure you don't have the high pressure waste gate can? If you do, that would explain your high boost. The high boost ones aren't designed to start opening until 15-16psi..
    83 Scamp GT, 2.5 TII/A-520
    89 Dodge Daytona ES turbo, Daily driver

  14. #14
    Garrett booster
    Join Date
    Sep 2009
    Location
    Central, NJ
    Posts
    211

    Re: Stock Boost Control Not Working

    That's what I get for posting before sufficient coffee. Thanks.

    I believe that I have a large can - this is the only one I've ever really played with. I'll connect the waste gate line to the turbo and see what happens.

    I haven't really jumped on it, but it definitely feels slower with stock boost control. I think the stock High Torque SBEC limited boost to 7psi under certain RPMs, I guess the MP might as well.


Similar Threads

  1. Replies: 8
    Last Post: 06-09-2016, 01:53 PM
  2. Replies: 9
    Last Post: 09-15-2012, 09:58 PM
  3. LM boost control v. boost spike problem
    By tryingbe in forum EFI Tuning
    Replies: 30
    Last Post: 02-01-2012, 10:37 AM
  4. boost button switchable boost level using cruise control question
    By boboli in forum Electrical & Fuel System
    Replies: 4
    Last Post: 01-31-2012, 01:40 PM
  5. T2 stock boost control components
    By Aries_Turbo in forum Turbos & Intercoolers!
    Replies: 2
    Last Post: 03-30-2007, 10:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •