Results 1 to 18 of 18

Thread: 89 Shelby Daytona Idle misfire

  1. #1
    Mitsu booster
    Join Date
    Mar 2016
    Location
    Utah
    Posts
    8

    89 Shelby Daytona Idle misfire

    Well, the title says it all.... I have an idle sputter/misfire. It runs great other than that. New plugs wires, rebuilt motor, cam timing is good, I donít know what else could be going on. No vacuum leaks. Timing is good. What could be causing this? It spits and sputters at idle and itís driving me nuts! Iím not sure where else to go. Is this a common issue? Any ideas? No CEL.

  2. #2
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,790

    Re: 89 Shelby Daytona Idle misfire

    Is it a pretty slight miss about ever 30 seconds or so?

  3. #3
    Mitsu booster
    Join Date
    Mar 2016
    Location
    Utah
    Posts
    8

    Re: 89 Shelby Daytona Idle misfire

    No itís constant sputter and misfire if I go by the exhaust put put put spit spit.... I think Iíll try and swap out the pick up coil. I know those things had issues.... I donít know where else to go

  4. #4
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,790

    Re: 89 Shelby Daytona Idle misfire

    You set the ign. timing with the coolant temp sensor unplugged, right?

  5. #5
    Mitsu booster
    Join Date
    Mar 2016
    Location
    Utah
    Posts
    8

    Re: 89 Shelby Daytona Idle misfire

    Yea I did I think I may have found the issue. There is a plastic plate that goes over the pickup coil that was missing, Iím gonna get one and put it on.... see what happens. My guess is, that plate acts as a barrier between the magnetic pickup and the rotor/cap so thereís no electrical interference.

  6. #6
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,790

    Re: 89 Shelby Daytona Idle misfire

    There is a piece of your HEP missing? Do you have a pic? Does the tach cut out when the miss occurs?

  7. #7
    Mitsu booster
    Join Date
    Mar 2016
    Location
    Utah
    Posts
    8

    Re: 89 Shelby Daytona Idle misfire

    Yes the top plastic cover peice.... no the tach doesnít cut out at all

  8. #8
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,790

    Re: 89 Shelby Daytona Idle misfire

    I'm confused as to exactly which piece is broken. Is it the splash shield piece which is screwed to the dist. and covers the cap and wires partially, or the plate over the HEP which is sandwiched between the cap and dist? If the tach doesn't cut out at all, I'll be surprised if the HEP is the cause. Normally, when there is a hep related issue and you're not getting signal, you lose the tach, as it's fed off of the HEP signal.

  9. #9
    Mitsu booster
    Join Date
    Mar 2016
    Location
    Utah
    Posts
    8

    Re: 89 Shelby Daytona Idle misfire

    It is the plate which is sandwiched in between the HEP and the cap/rotor

  10. #10
    Supporting Member II Turbo Mopar Contributor Dr. Johny Dodge's Avatar
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    1,323

    Re: 89 Shelby Daytona Idle misfire

    is it a round black plastic piece and can you see the wires leading to the pickups inside the dist ?

    sounds like the hep has sepperated into two pieces , upper and lower

    it's NOT supposed to be that way - it should be one piece

  11. #11
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,790

    Re: 89 Shelby Daytona Idle misfire

    Quote Originally Posted by Dr. Johny Dodge View Post
    is it a round black plastic piece and can you see the wires leading to the pickups inside the dist ?

    sounds like the hep has sepperated into two pieces , upper and lower

    it's NOT supposed to be that way - it should be one piece
    Indeed. I'm somewhat surprised that it's running with the thing apart like that.

  12. #12
    Mitsu booster
    Join Date
    Mar 2016
    Location
    Utah
    Posts
    8

    Re: 89 Shelby Daytona Idle misfire

    Yep it was running like hell! So I replaced it, and it seems to run much better and smoother when Iím driving. But still, It is sputtering at idle, when I go back to the tail pipe it spits and sputters. I turned the A/C on and when the compressor is running it smooths completely out. Go figure..? WTH. So when the engine is under load it idles great.

    - - - Updated - - -

    Yes it did, the top plate had separated

  13. #13
    Supporting Member II Turbo Mopar Contributor Dr. Johny Dodge's Avatar
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    1,323

    Re: 89 Shelby Daytona Idle misfire

    pics would be fantastic
    I think a lot , LOT of peeps would just love to see the inside of a hep

    - even if you have to email them to someone who can post them

  14. #14
    Moderator Turbo Mopar Staff Force Fed Mopar's Avatar
    Join Date
    Dec 2005
    Location
    Greenville/Spartanburg SC area
    Posts
    7,537

    Re: 89 Shelby Daytona Idle misfire

    I think you are just hearing the good old 2.2 burble
    Rob M.
    '89 Turbo GTC
    2.5 TIII swap is here!

    Project LookOwt
    '91 Daytona ES, 61k original miles, Rick Lozier's old 3.0 nitrous car
    Back to basics, then the mods go back on....

  15. #15
    Supporting Member II Turbo Mopar Contributor Dr. Johny Dodge's Avatar
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    1,323

    Re: 89 Shelby Daytona Idle misfire

    +1^
    the idle ranges up and down some to when sitting running for any extended length of time to

    it's supposed to ..

  16. #16
    Supporting Member Turbo Mopar Contributor 2.216VTurbo's Avatar
    Join Date
    Dec 2005
    Location
    SoCal the OC
    Posts
    6,660

    Re: 89 Shelby Daytona Idle misfire

    How noisy is your valvetrain? Would you say more than before rebuild or same? Did the lifters get replaced at rebuild? Reason I ask is Ive had weak lifters not 'do their job' at idle but when oil pressure goes up, they get happy again, strong aftermarket springs can exacerbate the problem. Its noisy tho, youll hear the clatter.

    Trying to wrap my head around why the AC on helps?? I wonder if you powered up the fan by jumping 12V to it at idle if that also has an effect?

    AJ (no More Alan) 84 Rampage RT TIII/568 Quaife 87 GLHS dealer optioned Red 16V Masi/568/Quaife
    90 Masi 16V White/Ginger/Black
    89 TC Masi 16V Red/Ginger/Black
    86 GLHS #110 RoadRace Built 89 CSX-VNT Recaro Car
    89 Turbo Mini 'Woody' 85 GLHT 'RedBox'
    2014 Explorer DD'r 3.5Twin Turbo Ecoboost AWD and 500HP
    My profile page has over 20,000 views, I'm somebody LOL

  17. #17
    Moderator Turbo Mopar Staff Force Fed Mopar's Avatar
    Join Date
    Dec 2005
    Location
    Greenville/Spartanburg SC area
    Posts
    7,537

    Re: 89 Shelby Daytona Idle misfire

    The load changes the spark scatter and fueling slightly I'd imagine. They do the same thing in auto cars, they pop and rumble in park and neutral, drop it in gear and it stops.

    In my Shelby Z with the FM475 cam, it loped until one day I noticed it was kinda on the lean side idling, added fuel a bit of fuel to get 14.5-14.7 and suddenly it didn't lope anymore and idle was smooth...Also, I found that adding timing at idle in my Lebaron on the 2.5 smoothed things out a bit. So, probably an idle emissions thing.
    Rob M.
    '89 Turbo GTC
    2.5 TIII swap is here!

    Project LookOwt
    '91 Daytona ES, 61k original miles, Rick Lozier's old 3.0 nitrous car
    Back to basics, then the mods go back on....

  18. #18
    Supporting Member Turbo Mopar Contributor 2.216VTurbo's Avatar
    Join Date
    Dec 2005
    Location
    SoCal the OC
    Posts
    6,660

    Re: 89 Shelby Daytona Idle misfire

    Rob makes a great point, easy test. Close your plug gaps to .028 and see if sputter goes away?

    AJ (no More Alan) 84 Rampage RT TIII/568 Quaife 87 GLHS dealer optioned Red 16V Masi/568/Quaife
    90 Masi 16V White/Ginger/Black
    89 TC Masi 16V Red/Ginger/Black
    86 GLHS #110 RoadRace Built 89 CSX-VNT Recaro Car
    89 Turbo Mini 'Woody' 85 GLHT 'RedBox'
    2014 Explorer DD'r 3.5Twin Turbo Ecoboost AWD and 500HP
    My profile page has over 20,000 views, I'm somebody LOL

Similar Threads

  1. Idle problems on '87 Shelby CSX
    By iTurbo in forum Electrical & Fuel System
    Replies: 8
    Last Post: 11-17-2013, 08:46 AM
  2. Misfire at idle and cruise
    By INVUJerry in forum "I need help!"
    Replies: 46
    Last Post: 01-24-2013, 11:28 PM
  3. 87 daytona shelby z high Idle.
    By shackwrrr in forum "I need help!"
    Replies: 2
    Last Post: 11-02-2010, 01:48 AM
  4. Idle Misfire and Misfire at 5500 RPMs
    By turbodaytona87 in forum "I need help!"
    Replies: 4
    Last Post: 07-13-2010, 11:17 PM
  5. 88 shelby z high idle
    By schenkr88 in forum "I need help!"
    Replies: 2
    Last Post: 07-01-2009, 09:45 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •