Results 1 to 17 of 17

Thread: 86 Daytona: runs like crap after 2 years of sitting

  1. #1
    Authorized Vendor Turbo Mopar Vendor
    Join Date
    Feb 2007
    Location
    Tempe,AZ
    Posts
    1,289

    86 Daytona: runs like crap after 2 years of sitting

    1986 Daytona Turbo

    hasn't run in 2 years. installed new battery.

    cranked it and fuel spewed out of the hose to the fuel rail.

    replaced it and the one to the pressure regulator.

    it runs but sputters like it is on 3 cylinders and if you give it gas the idle does not change.


    so bad fuel in the tank? what squirted out did not smell like old gas in particular. pulled the gas cap and no horrible smell.

    last time it ran it ran perfect.


    any ideas?

  2. #2
    turbo addict
    Join Date
    Dec 2005
    Location
    Sylmar, CA
    Posts
    2,481

    Re: 86 Daytona: runs like crap after 2 years of sitting

    A good start is to check codes; turn key three times and count check engine light flashes.
    John Laing "The sole condition which is required in order to succeed in centralizing the supreme power in a democratic community, is to love equality, or to get men to believe you love it. Thus the science of despotism, which was once so complex is simplified, and reduced . . . . to a single principle." -- Alexis de Tocqueville "One of the methods used by statists to destroy capitalism consists in establishing controls that tie a given industry hand and foot, making it unable to solve its problems, then declaring that freedom has failed and stronger controls are necessary." --Ayn Rand "To evolve, you don't need a Constitution. All you need is a legislature and a ballot box . . . . things will evolve as much as you want. All of these changes can come about democratically; you don't need a Constitution to do that and it's not the function of a Constitution to do that." -- Justice Antonin Scalia

  3. #3
    Supporting Member II Turbo Mopar Contributor ajakeski's Avatar
    Join Date
    Sep 2007
    Location
    SE Wisconsin
    Posts
    2,438

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Check the ground from the fuel rail to the firewall.

    Could also be a bad injector, or a bad connection or wire in the harness.

    If you have a cylinder without fuel, you can isolate it by disconnecting one plug wire at a time while it's running. The conditions should get worse each time (ie running on 2) until you reach the problem cylinder.

  4. #4
    Super Moderator Turbo Mopar Staff contraption22's Avatar
    Join Date
    Dec 2005
    Location
    Havertown, PA
    Posts
    9,306

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Crappy fuel deteriorated your fuel hoses. It's a possibility that some of that stuff ended up in your injectors. I am not saying I feel it's 100% your issue, but fuel system contamination would be high on my list of suspects.
    Mike Marra
    1986 Plymouth Horizon GLMF "The Contraption" < entertaining sponsorship offers
    Project Log:
    http://www.turbo-mopar.com/forums/showthread.php?69708-The-Contraption-2013-14&highlight=

    1983 Dodge Rampage FOR SALE 37K original Miles. Needs work. But solid body and chassis. Trying to avoid a partout. Make me an offer.

  5. #5
    Authorized Vendor Turbo Mopar Vendor
    Join Date
    Feb 2007
    Location
    Tempe,AZ
    Posts
    1,289

    Re: 86 Daytona: runs like crap after 2 years of sitting

    when I have the chance will drop the filter...........

  6. #6
    Boost, it's what's for dinner... Turbo Mopar Staff Aries_Turbo's Avatar
    Join Date
    Dec 2005
    Location
    Warsaw, NY
    Posts
    8,096

    Re: 86 Daytona: runs like crap after 2 years of sitting

    warning.... i go to extremes.

    id drop the tank and flush it out, flush the fuel hoses and swap in clean injectors and fuel pressure regulator.

    id also replace all the rubber hoses.... inside the tank and out.

    this is what i did after my car sat for 8 years. runs mint other than my tune not being dialed in.

    Brian

    Quote Originally Posted by turbovanman
    This one is easy, I have myself to blame, I rush things, don't pay attention to gauges when I should, change to much stuff at once then expect miracles, the list is endless.

  7. #7
    Garrett booster
    Join Date
    Jan 2007
    Location
    Baltimore, MD
    Posts
    103

    Re: 86 Daytona: runs like crap after 2 years of sitting

    If you drop the tank, I would replace the strainer on the fuel pump. Cut your old fuel filter open and look for rust on it. I had to replace my tank because it was full of rust.

  8. #8
    Authorized Vendor Turbo Mopar Vendor
    Join Date
    Feb 2007
    Location
    Tempe,AZ
    Posts
    1,289

    Re: 86 Daytona: runs like crap after 2 years of sitting

    tried to start it 2 days later, will not fire.

    dropped fuel filter lines and there is lots of gas coming out of the tank. it smells OK.

    the filter has about 40 miles on it so that is not an issue.



    code 12 Battery or computer recently disconnected...that is correct

    then code 55 End of codes


    fuel pump was new when I replaced the tank and has less than 100 miles on it.

  9. #9
    Supporting Member II Turbo Mopar Contributor ajakeski's Avatar
    Join Date
    Sep 2007
    Location
    SE Wisconsin
    Posts
    2,438

    Re: 86 Daytona: runs like crap after 2 years of sitting

    An engine need three thngs to compression, fuel and spark.

    Check your HEP and all the harness connectors. That's the easiest place to start.

  10. #10
    turbo addict
    Join Date
    Dec 2005
    Location
    Mesa, AZ
    Posts
    6,946

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Car started with carb cleaner, my money is on fuel injectors are clogged.

  11. #11
    Authorized Vendor Turbo Mopar Vendor
    Join Date
    Feb 2007
    Location
    Tempe,AZ
    Posts
    1,289

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Yes Harry's suggestion worked so will replace the injectors

  12. #12
    Super Moderator Turbo Mopar Staff contraption22's Avatar
    Join Date
    Dec 2005
    Location
    Havertown, PA
    Posts
    9,306

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Don't bother replacing the injectors unless you've replaced all the soft parts in the fuel system.
    Mike Marra
    1986 Plymouth Horizon GLMF "The Contraption" < entertaining sponsorship offers
    Project Log:
    http://www.turbo-mopar.com/forums/showthread.php?69708-The-Contraption-2013-14&highlight=

    1983 Dodge Rampage FOR SALE 37K original Miles. Needs work. But solid body and chassis. Trying to avoid a partout. Make me an offer.

  13. #13
    Supporting Member II Turbo Mopar Contributor minigts's Avatar
    Join Date
    Dec 2005
    Location
    Memphis, TN
    Posts
    6,656

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Quote Originally Posted by contraption22 View Post
    Don't bother replacing the injectors unless you've replaced all the soft parts in the fuel system.
    Sage advice.


    Jon Trotter

    1985 Dodge Shelby Charger, Currently decommissioned
    1987 Shelby GLHS, #937
    1987 Shelby Lancer, #628

    Quote Originally Posted by Reeves View Post
    I can be ready. Please send pics of wife.
    _____DodgeZ add comments here______

  14. #14
    Hybrid booster
    Join Date
    Mar 2014
    Location
    Toronto Canada
    Posts
    881

    Re: 86 Daytona: runs like crap after 2 years of sitting

    Mouse junk in air cleaner?

  15. #15
    Authorized Vendor Turbo Mopar Vendor
    Join Date
    Feb 2007
    Location
    Tempe,AZ
    Posts
    1,289

    Re: 86 Daytona: runs like crap after 2 years of sitting

    No mouse problems here only giant rats with 2 legs that masquerade as humans!

    I live in a large metro area ....Tempe. No small mammals dancing around here.

    Injectors have been ordered.

    All the rubber fuel lines are new.

  16. #16
    Hybrid booster
    Join Date
    Nov 2006
    Location
    CT
    Posts
    590

    Re: 86 Daytona: runs like crap after 2 years of sitting

    I just went through this and after cleaning the injectors and getting a good spray out of them, the car still didn't run right. Turned out the fuel had also deteriorated the diaphragm in fuel pressure regulator just like it had deteriorated the fuel lines. You may want to pull the vacuum hose off of that and see if any fuel comes out of the nipple. If so, replace that while you're replacing the injectors.

  17. #17
    Authorized Vendor Turbo Mopar Vendor
    Join Date
    Feb 2007
    Location
    Tempe,AZ
    Posts
    1,289

    Re: 86 Daytona: runs like crap after 2 years of sitting

    installed NOS injectors


    runs like new


    the old ones had a nice coating of dried goo on them.

Similar Threads

  1. 88 daytona shelby z 14 years of sitting
    By daytonadude in forum The Original "Turbo Dodge" Cars
    Replies: 6
    Last Post: 07-11-2013, 11:29 PM
  2. car runs like crap
    By brokendaytona in forum "I need help!"
    Replies: 6
    Last Post: 12-02-2010, 06:44 PM
  3. Starting a car thats been sitting for 10+ Years
    By omni_840 in forum Maintenance & General Tech
    Replies: 8
    Last Post: 12-29-2009, 02:03 AM
  4. starting a motor thats been sitting for 1.5 years????????
    By shelbyplaya in forum Engine - Block, Piston, Heads, Intakes
    Replies: 11
    Last Post: 05-22-2009, 09:44 AM
  5. Replies: 64
    Last Post: 03-30-2009, 10:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •