Results 1 to 9 of 9

Thread: Help troubleshooting MPScan

  1. #1
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,461

    Help troubleshooting MPScan

    Having some trouble with MPScan.
    I was having connection issues last Nov or so before dropping MeanMini off at Brian's shop.
    Now that she is back, I am trying to get some logs so i can make some tuning adjustments.
    I am getting errors that say failed to connect and to cycle the key off-on. But, it does not work, and then when I click record again it closes MPScan abruptly.

    Here is the port log:
    mpscan ver - 2.0.3.3 (3/4/2016 1:15:21 PM)
    Microsoft Windows XP Professional - Win32NT
    trying to open port COM17 - ctlrecord_click
    got a good port back - ctlrecord_click
    try to open port COM17 -initport
    COM17 is a legit port -initport
    usb is available on COM17 -initport
    usb ftdi serial number BBS3XE4O2J is available - initport
    [usbportinit] setting port baud rate to 7812
    ftdi open successful on COM17 -usbportinit
    using protocol SMEC T1:1
    attempt to change ecu baud rate to 62500
    Sending byte 18
    Received 0 byte(s): 0
    Read confirm byte failed (status:0 - count:0)
    Sending byte 18
    Received 0 byte(s): 0
    Read confirm byte failed (status:0 - count:0)
    Sending byte 18
    Received 0 byte(s): 0
    Read confirm byte failed (status:0 - count:0)
    Sending byte 18
    Received 0 byte(s): 0
    Read confirm byte failed (status:0 - count:0)
    usbsethibaud failed - usbportinit
    ftdi open unsuccessful - usbportinit
    Sending byte 254
    Received 0 byte(s): 0
    Read confirm byte failed (status:0 - count:0)
    Sending byte 254
    Received 0 byte(s): 0
    Read confirm byte failed (status:0 - count:0)
    can't open ftdi port - usbportinit
    Unable to open/setup port. - ctlrecord_click


    Here is the Coms:
    -Comport analysis for mpscan version 2.0.3.3 (3/4/2016 1:12:23 PM)
    -Locating ports on computer-
    name:USB Serial Port (COM17) deviceid:FTDIBUS\VID_0403+PID_6001+BBS3XE4O2JA\000 0
    name:Communications Port (COM1) deviceid:ACPI\PNP0501\4&61F3B4B&0
    number of ftdi devices found - 1
    ftdi port num:COM17 serial num:BBS3XE4O2J
    Inverted tx:True Inverted rx:True
    Vcp driver loaded:True
    Latency is set to:16
    checking to see if usb port number COM17 is a moates device
    Moates device not located on this port
    default com port set to:COM17

    I'm wondering if it is a bad cable?
    Is that baud rate change correct?

    I did try MPScan on Slugmobile and it made a log, but don't know if it was some sampling issue as it looked like several duplicated readings.

    Any help from the smart folks is appreciated. Was hoping to possibly race this Sunday, if I can get some logs and make some adjustments tomorrow.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  2. #2
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,461

    Re: Help troubleshooting MPScan

    How can you get to what's in this error report?
    Click image for larger version. 

Name:	uploadfromtaptalk1457133341241.jpg 
Views:	38 
Size:	34.3 KB 
ID:	57465

    I just tried the other cable I had, and same problem. I updated all the setup files, and still same problem.
    Here is the port log 9you can see the different cable, shows port 14):
    mpscan ver - 2.0.3.3 (3/4/2016 6:09:02 PM)
    Microsoft Windows XP Professional - Win32NT
    trying to open port COM14 - ctlrecord_click
    got a good port back - ctlrecord_click
    try to open port COM14 -initport
    COM14 is a legit port -initport
    usb is available on COM14 -initport
    usb ftdi serial number BBVGDESB is available - initport
    [usbportinit] setting port baud rate to 7812
    ftdi open successful on COM14 -usbportinit
    using protocol SMEC T1:1
    attempt to change ecu baud rate to 62500
    Sending byte 18
    Received 1 byte(s): 18
    Changing mpscan baud rate to 62500
    Sending byte 242
    Received 1 byte(s): 242
    Byte 242 was sent 1 times to make the change.
    usb ftdi
    Successfully opened port - ctlrecord_click

    And the Coms:
    -Comport analysis for mpscan version 2.0.3.3 (3/4/2016 6:08:24 PM)
    -Locating ports on computer-
    name:USB Serial Port (COM14) deviceid:FTDIBUS\VID_0403+PID_6001+BBVGDESBA\0000
    name:Communications Port (COM1) deviceid:ACPI\PNP0501\4&61F3B4B&0
    number of ftdi devices found - 1
    ftdi port num:COM14 serial num:BBVGDESB
    Inverted tx:True Inverted rx:True
    Vcp driver loaded:False
    Latency is set to:2
    checking to see if usb port number COM14 is a moates device
    Moates device not located on this port
    default com port set to:COM14
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  3. #3
    Visit www.boostbutton.com... Turbo Mopar Contributor ShelGame's Avatar
    Join Date
    Dec 2005
    Location
    Whitmore Lake, Michigan, Unite
    Posts
    9,918

    Re: Help troubleshooting MPScan

    VCP Driver loaded: false
    I think this is the issue.

    Go here -- http://www.boostbutton.com/turbonato...id=cable_setup

    About halfway down, look for the section called "Setup the USB to SCI cable". You'll need to open Windows Device manager and force it to load the VCP driver.
    https://db.tt/SV7ONZpQ
    Rob Lloyd
    '89 Daytona C/S

    2.5 T1 Auto
    13.24 @ 100.5mph
    NHRA #3728 AF/S

    boostbutton.com
    tuning wiki

  4. #4
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,461

    Re: Help troubleshooting MPScan

    That is setup. Just Checked both cables.

    and just tried again, and mpscan just closed out as soon as I hit record.

    mpscan ver - 2.0.3.3 (3/4/2016 7:44:36 PM)
    Microsoft Windows XP Professional - Win32NT
    trying to open port COM17 - ctlrecord_click
    got a good port back - ctlrecord_click
    try to open port COM17 -initport
    COM17 is a legit port -initport
    usb is available on COM17 -initport
    usb ftdi serial number BBS3XE4O2J is available - initport
    [usbportinit] setting port baud rate to 7812
    ftdi open successful on COM17 -usbportinit
    using protocol SMEC T1:1
    attempt to change ecu baud rate to 62500
    Sending byte 18
    Received 1 byte(s): 18
    Changing mpscan baud rate to 62500
    Sending byte 242
    Received 1 byte(s): 242
    Byte 242 was sent 1 times to make the change.
    usb ftdi
    Successfully opened port - ctlrecord_click


    -Comport analysis for mpscan version 2.0.3.3 (3/4/2016 7:43:16 PM)
    -Locating ports on computer-
    name:USB Serial Port (COM17) deviceid:FTDIBUS\VID_0403+PID_6001+BBS3XE4O2JA\000 0
    name:Communications Port (COM1) deviceid:ACPI\PNP0501\4&61F3B4B&0
    number of ftdi devices found - 1
    ftdi port num:COM17 serial num:BBS3XE4O2J
    Inverted tx:True Inverted rx:True
    Vcp driver loaded:True
    Latency is set to:16
    checking to see if usb port number COM17 is a moates device
    Moates device not located on this port
    default com port set to:COM17
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  5. #5
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Jun 2006
    Location
    Spearfish SD
    Posts
    1,983

    Re: Help troubleshooting MPScan

    send me your mpc file you are trying to work with and i'll see if i can recreate this issue. your last post looks like it connected properly. for mpscan to bomb out light that without an error is very weird. also, look in the same directory the coms logs you posted above were in and see if there is a file called mptapperr.txt. i'm curious if there is and what it may say.
    89 Voyager LE, 2.5T2 - rest in peace
    87 Charger Shelby T2 (2.4 conversion in process)

  6. #6
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,461

    Re: Help troubleshooting MPScan

    Thanks Morris. I'll be back at the house this afternoon and i'll post it. I don't remember seeing another text file, but i will look.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  7. #7
    Supporting Member II Turbo Mopar Contributor
    Join Date
    Jun 2006
    Location
    Spearfish SD
    Posts
    1,983

    Re: Help troubleshooting MPScan

    wayne - sent you an email.
    89 Voyager LE, 2.5T2 - rest in peace
    87 Charger Shelby T2 (2.4 conversion in process)

  8. #8
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,461

    Re: Help troubleshooting MPScan

    Not exactly sure what i did, but i just got a successful connect and log.

    Will update more in a bit.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

  9. #9
    Slugmobile & MeanMini Caretaker Turbo Mopar Contributor wheming's Avatar
    Join Date
    Nov 2010
    Location
    Raleigh Area, NC
    Posts
    4,461

    Re: Help troubleshooting MPScan

    MPScan has been kind of spotty for me. Today it worked when i tried it. The other day after i posted it was working i had trouble connecting again.

    Not sure if it is something wrong with my laptop or what. But i got some run logs today.
    Wayne H.

    '91 Dodge Spirit ES 2.5L turbo 5spd
    '05 PT GT 2.4T HO autostick
    '89 Plymouth Acclaim 2.5L turbo auto, "Slugmobile" yes, THE Slugmobile!
    '89 Dodge Caravan SE 2.5L turbo auto, "Mean Mini" yes, Gus' Mean Mini! (Current best 11.7786@113.04 mph! - Jan 15th, 2017 Fayetteville Dragway, NC)
    MeanMini dragracing videos: https://www.youtube.com/playlist?lis...URZLB1RxGYF6vw
    and other cars, trucks and motorcycles
    https://www.youtube.com/user/SlugmobileMeanMini

Similar Threads

  1. Turn Signal Troubleshooting
    By williestargell in forum Electrical & Fuel System
    Replies: 3
    Last Post: 10-12-2015, 07:58 AM
  2. Troubleshooting with MPSCAN
    By wallace in forum EFI Tuning
    Replies: 0
    Last Post: 01-02-2015, 03:06 PM
  3. Troubleshooting Cruise Control
    By DoubleD in forum Electrical & Fuel System
    Replies: 12
    Last Post: 06-13-2014, 05:43 PM
  4. Troubleshooting PO134 / 1995 DOHC ACR
    By guyd_15 in forum Other vehicles
    Replies: 2
    Last Post: 05-22-2009, 10:21 AM
  5. Cooling system: Flush/troubleshooting.
    By 85_600 in forum Maintenance & General Tech
    Replies: 2
    Last Post: 05-27-2006, 11:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •