Results 1 to 14 of 14

Thread: clutch pedal prob

  1. #1
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    clutch pedal prob

    i hooked up the clutch cable today in the glht and it sticks out about 3" past the brake petal. when i hooked it up the first time the cable came off the cam like thing on the petal itself on the inside . so i unhooked it at the trans and put it all back on inside the hooked it all back up . now the petal sticks out past the brake . something is wrong with it . i tried to stand on my head to see under the dash . but i guess my head is to big to see anything .lol anyone know what could be causing this ?
    the car is a 85 glht with a 523 trans stock clutch cable .

    thanks
    billy

  2. #2

    Re: clutch petal prob

    I did my best to take pictures showing the difference in pedal height. This is in my '83 Shelby Charger.. It's at least 2", possibly 3.. I think it's normal..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	pedals1.jpg 
Views:	44 
Size:	43.5 KB 
ID:	193   Click image for larger version. 

Name:	pedals2.jpg 
Views:	45 
Size:	46.3 KB 
ID:	194   Click image for larger version. 

Name:	pedals3.jpg 
Views:	43 
Size:	35.9 KB 
ID:	195  

  3. #3
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    Re: clutch petal prob

    yeah mine dont look nothing like that . i just ran out and put a straight edge across the brake petal and measured to the clutch petal and its 3 3/4 "
    is there a stop under there somewhere ?

  4. #4
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    Re: clutch petal prob

    it looks like the clutch cable im using is to short . im using the stock glht cable . anyone ever have this prob before ?

  5. #5

    Re: clutch petal prob

    You can re-clock the arm on the transmission if the cable is too short. Never heard of too short, usually just too long from stretching..

  6. #6
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    Re: clutch petal prob

    ok , so if i moved the arm up a lil then that might take care of my prob . i looked at it today and the spring on the back of the petal is open alot and the lil clip that slides up and down is all the way at the top and wont move when u push the petal down . so that might just fix it .
    thanks for the help una . if that dont fix it all post again here .

    billy

  7. #7
    turbo addict
    Join Date
    Dec 2005
    Location
    Gettysburg, Pa.
    Posts
    1,699

    Re: clutch petal prob

    Quote Originally Posted by Una
    You can re-clock the arm on the transmission if the cable is too short. Never heard of too short, usually just too long from stretching..
    You *CAN NOT* re-clock the arm on the trans. It will not let you. The arm and the end of the shaft are notched much like a steering wheel so that they only go on one way.....

    Billy, does that clutch seem to be working properly the way it is?

    T

  8. #8

    Re: clutch petal prob

    Quote Originally Posted by turbojerk
    You *CAN NOT* re-clock the arm on the trans. It will not let you. The arm and the end of the shaft are notched much like a steering wheel so that they only go on one way.....

    Billy, does that clutch seem to be working properly the way it is?

    T
    You're right.. Takes 5 seconds with a dremel cutoff disc to fix the splines.. It's a pretty common thing to reclock the arm..

  9. #9
    turbo addict
    Join Date
    Dec 2005
    Location
    Gettysburg, Pa.
    Posts
    1,699

    Re: clutch petal prob

    Quote Originally Posted by Una
    You're right.. Takes 5 seconds with a dremel cutoff disc to fix the splines.. It's a pretty common thing to reclock the arm..
    True enough, but I don't think that it's solving the problem. You shouldn't have to do all of that. I know I didn't do it on my GLH-T, nor did anyone I know that replace the original trans with an A523/520. Obviously, if there is a problem, it lies elsewhere. If the cable is that stretched, it should be replaced now before it leaves him stranded somewhere....

    This may be a stupid question Billy, but what does the brake petal feel like? Are you sure it's not the brakes instead of the clutch?

    T

  10. #10
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    Re: clutch petal prob

    brake petal is up where it should be . i took the clutch petal out to get a better look at it and everything looks fine . put everything back the way it goes and i still have the prob . clutch is still way up past the brake . i tried to see if a g body cable would work and it wont .lol i dont get it !!!

  11. #11
    Supporting Member Turbo Mopar Contributor mock_glh's Avatar
    Join Date
    Jan 2006
    Location
    Duarte, CA
    Posts
    621

    Lightbulb Re: clutch pedal prob

    There is a stop for the clutch pedal on the dashboard side of the pedal bracket. The rubber piece may have fallen off and allowed the pedal to come up higher. The pedal needs to be higher than the brake to allow enough throw to release the clutch.

  12. #12
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    Re: clutch pedal prob

    do u happen to have a pic of that mock ? i dont see anything that stops it on mine . i didnt think there would be a stop since u have to pull up on the clutch to adjust the cable .

  13. #13

    Re: clutch pedal prob

    The stop is what your pulling against when you pull up to adjust.

  14. #14
    Hybrid booster
    Join Date
    Dec 2005
    Location
    martinsburg w.v
    Posts
    299

    Re: clutch pedal prob

    ok i didnt see any stop at all . that might be the prob lol

Similar Threads

  1. reducing clutch pedal travel?
    By cs daytona in forum Transmission
    Replies: 1
    Last Post: 08-14-2007, 11:10 PM
  2. shifting problems
    By "Top Fuel" Bender in forum Cummins Turbo Diesel
    Replies: 15
    Last Post: 04-17-2007, 08:23 PM
  3. clutch pedal broke....
    By TurboXT in forum Transmission
    Replies: 10
    Last Post: 05-17-2006, 03:42 PM
  4. stupid clutch pedal miraculously fixed...
    By zshadow in forum Transmission
    Replies: 4
    Last Post: 05-10-2006, 01:54 AM
  5. stupid clutch pedal...
    By zshadow in forum "I need help!"
    Replies: 0
    Last Post: 03-25-2006, 04:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •