Results 1 to 3 of 3

Thread: Guage cluster electrical issues.

  1. #1
    Garrett booster
    Join Date
    Jan 2006
    Location
    Pittsburgh, Pa
    Posts
    174

    Guage cluster electrical issues.

    My 90 shelby is really pissing me off. I just started driving it again the other day. The tack decides when it wants to work all the time but I already tried all the fixes and am more concerned about the other issues. My check engine light seems to no longer function. The check guages doesn't light up either but I don't remember if that does when you key it on or not. The voltage guage decided to not work anymore but it was the other day. The temp guage seems to have stopped as well since today. I pulled the cluster out and tried different bulbs even though they didn't look blown. Took my parking light bulb and holder and swapped it into the check engine spot since I knew that worked and still nothing. Reflowed every solder joint on the back of the cluster board. Still no luck. Swapped in an extra body computer I have. No luck. Swapped in a spare SBEC no luck. Unplugged, inspected the wiring harness that runs across the front of the engine from by the battery. Uhhhghhhh. Im gonna try to run a wire from the battery pos to the 1 side of the check engine light and ground the other just to verify it works and then I guess back track.

  2. #2
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,821

    Re: Guage cluster electrical issues.

    The first thing I would do would be to probe the connectors which go into the cluster to see if you are getting a signal when you should. If so, cluster related, if not crazy wiring problem most likely.

  3. #3
    Garrett booster
    Join Date
    Jan 2006
    Location
    Pittsburgh, Pa
    Posts
    174

    Re: Guage cluster electrical issues.

    The voltage and temp guage seem to be working now but still no luck with the check engine light. Where does the light even get this signal from? Body computer or SBEC or something else?

Similar Threads

  1. Electrical issues 89 lebaron vert
    By turbo-baron in forum Electrical & Fuel System
    Replies: 0
    Last Post: 05-02-2011, 10:30 PM
  2. Interior Lbody Guage Cluster
    By contraption22 in forum Parts Wanted
    Replies: 21
    Last Post: 10-24-2010, 07:25 PM
  3. L-body Guage Cluster Interchangability
    By contraption22 in forum Interior, Exterior and Chassis Modifications
    Replies: 7
    Last Post: 08-23-2010, 12:33 PM
  4. If you think you have oil pressure gauge issues-read here!!!!
    By turbovanmanČ in forum Engine - Block, Piston, Heads, Intakes
    Replies: 27
    Last Post: 05-06-2010, 09:40 AM
  5. Mini guage cluster and nitrous button
    By fastasleep in forum Interior, Exterior and Chassis Modifications
    Replies: 6
    Last Post: 12-13-2007, 11:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •