Rock Auto - Prime Ad
Results 1 to 16 of 16

Thread: 42RE transmission problems

  1. #1
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    42RE transmission problems

    my friend has a dakota 2wd with the 42RE transmission. He used to be a tech at the local chrysler dealership and did most of the transmission work for them. he just rebuilt the transmission because of a shifting problem but it didn't fix the problem. The truck has 2nd gear and 4th gear but no 1st or 3rd. He said something about it being the gov pressure sensor and solenoid. Are there any other things that could cause this? I'm thinking about grabbing a powertrain control module at the JY tomorrow too. Any other ideas?

  2. #2
    Hybrid booster
    Join Date
    May 2009
    Location
    Englewood, FL
    Posts
    860

    Re: 42RE transmission problems

    I always thought the problem with those trannys was the pump went out?

    But...when you say theres no 1st or 3rd...do you mean when you shift it manually? Or when you just put it in drive and go? Or both?

  3. #3
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    Re: 42RE transmission problems

    both, he said that he put a new pump and valve body in it and it didnt fix the problem.

  4. #4
    The moderately moderate moderator Turbo Mopar Staff black86glhs's Avatar
    Join Date
    Dec 2006
    Location
    Akron, Ohio
    Posts
    6,368

    Re: 42RE transmission problems

    What about a shift solenoid? If he swaps solenoids does it change from 1 & 3 to 2 & 4 not working?
    Bryan
    86 GLHS #161
    SDAC National Member
    SDAC Buckeye Chapter Member

    P.S. If you shat yourself on purpose to end the evening early......touche`..

  5. #5
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    Re: 42RE transmission problems

    i'll put it on my list of stuff to get tomorrow lol. aren't those just located on the outside of the trans?

  6. #6
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    Re: 42RE transmission problems

    he hasn't tried swapping solenoids to my knowledge. but that's a good idea, i'm pretty unfamiliar with these transmissions but a shift solenoid would make sense.

  7. #7
    The moderately moderate moderator Turbo Mopar Staff black86glhs's Avatar
    Join Date
    Dec 2006
    Location
    Akron, Ohio
    Posts
    6,368

    Re: 42RE transmission problems

    On other transmissions(besides the A604) they are on the valve body. I personally don't know if the 42RE has them, but it was the first thing I could think of that would affect it before and after rebuild.
    Bryan
    86 GLHS #161
    SDAC National Member
    SDAC Buckeye Chapter Member

    P.S. If you shat yourself on purpose to end the evening early......touche`..

  8. #8
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    Re: 42RE transmission problems

    it's a 1996 transmission so i would have to believe it would but who knows. I'm basically going to grab all the sensors/solenoids i can find at the yard and start changing them one at a time and see what happens. he said that its not throwing any codes which is odd, either way we'll see what happens and I'll post my findings.

  9. #9
    turbo addict JDAWG's Avatar
    Join Date
    Dec 2005
    Location
    Hagerstown, Maryland, United S
    Posts
    2,477

    Re: 42RE transmission problems

    yea governor pressure sensor and transducer, i sold a boat load of those

  10. #10
    Garrett booster
    Join Date
    Apr 2009
    Location
    Fallbrook, CA
    Posts
    102

    Re: 42RE transmission problems

    If he put a new valve body in, then it would have a new solenoid and transducer. Or did he just recondition the valve body?

  11. #11
    Garrett booster
    Join Date
    Aug 2007
    Location
    va
    Posts
    58

    Re: 42RE transmission problems

    Most of the time when there is a problem with the gov pressure transducer or solenoid it won't downshift to 1st. It will stay in 3rd gear when coming to a stop.

  12. #12
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    Re: 42RE transmission problems

    well come to find out he refurbished the valve body and didn't replace any of the solenoids lol. We just ordered the gov pressure sensor and solenoid yesterday so those will most likely be replaced this weekend and we'll go from there. If those don't fix it my next guess would be the PCM. according to the shop manual he has for the truck, on the troubleshooting tree it says either PCM or GOV pressure sensor for these symptoms so we'll see.

  13. #13
    Hybrid booster
    Join Date
    Feb 2007
    Location
    Findlay Ohio
    Posts
    416

    Re: 42RE transmission problems

    well i fixed it. the problem was the PCM not sending the signal to the relay to send power to the transmission solenoids. So rather than get a new PCM i just installed a wire directly off the battery going to the solenoids with a switch and a fuse on it. runs like a champ.

  14. #14
    Mitsu booster
    Join Date
    Dec 2011
    Location
    illinois
    Posts
    1

    Re: 42RE transmission problems

    ive got a 1997 godge dakota pick-up its got a 3.9 liter motornwitha 42-RE transmission in it when i traded for the truck the woman i got it from said she took it to a garage and they told he the toque converter was going out on it, i talked to a guy who suposabley rebuilds transmissions and he told me that the clutches were going out of the tranmission but anyways if someone can tell me if they have had the same problems youre input would be helpfull, anyways here we go the thing will go into drive fine it will take off fine but when im going down the road in it it will loose all power then i can come to a stop and you can feel it go back into gear once in awhile if i get slowed down enough it will take without stopping the other day i took off in it and it had all kinds of power going around a couple of blocks then started to slip and started acting up again anyways the woman who had it before me said she had the trany fluid changed a couple of weeks before i got it and it run good for a couple of weeks then started acting up again this has got me puzzled sincs they want 575 for a used tranny and 1200 for a new one since i cant afford either right now any input would be appreciated.

  15. #15
    Buy my stuff!!!!!!!!!!! :O) Turbo Mopar Vendor turbovanmanČ's Avatar
    Join Date
    Dec 2005
    Location
    Abbotsford, BC
    Posts
    43,489

    Re: 42RE transmission problems

    Check for codes, then maybe drop the pan and check for crud in the pan, replace the filter and refill with the proper fluid, it could have been filled with Dexron, it takes ATF +3 or +4 IIRC.
    1989 FWD Turbo Caravan-2.5 TIII, GT35R, auto, a/c, cruise, pwr windows/locks, fully loaded with interior and ran with full exhaust. RETIRED FOR A FEW YEARS! 12.57@104 :O)
    1984 Chev Getaway van, 6.2 Diesel with a remote mounted turbo setup burning WMO.
    1989 Mini-me turbo Caravan, going for the van record, NO NOS!

    Aurora ignition wires for sale. Link to info

    Super60 roller cams or custom/billet cams. Link to info

    TIII adapter plates for a dizzy.Link to info.

  16. #16
    Mitsu booster
    Join Date
    Jan 2012
    Location
    texas
    Posts
    1

    Re: 42RE transmission problems

    i don,t know if this qualifys as topic, but here is my issue i have 1st and riverse on a 99 dodge 1500 .
    i droped the pan and saw the black muck and fluid this trany only has 83000 miles on it, it will not shift,
    even when i try manuly. do i have to rebuild or could it be a sensor ? and thair are no trouble codes.

Similar Threads

  1. Transmission info posted on Neons.org
    By Dodge Aries K in forum Transmission
    Replies: 26
    Last Post: 06-21-2008, 08:26 AM
  2. Honda transmission problems
    By ShadowFromHell in forum Other vehicles
    Replies: 4
    Last Post: 11-17-2007, 10:11 PM
  3. Replies: 3
    Last Post: 01-31-2007, 01:05 PM
  4. Hybrid Transmission Sales
    By Cliff Ramsdell in forum General Vendor Area
    Replies: 13
    Last Post: 11-26-2006, 05:18 PM
  5. Manual Transmission Fluid Change
    By Subliminal in forum Old FAQ Info
    Replies: 0
    Last Post: 12-21-2005, 12:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •