Results 1 to 3 of 3

Thread: EGT reading..

  1. #1
    Hybrid booster Turbo Mopar Contributor Turbo_Rampage's Avatar
    Join Date
    Jan 2006
    Location
    Edmonton, Alberta, Canada
    Posts
    662

    EGT reading..

    Hey, I just installed my Auto Meter EGT gauge today in the #4 runner (about 1" from the cylinder head) and i have a few questions about my EGT reading.. When i fire it up it goes to 900* in about 30 seconds and stays their even at operating temp which is good, right? Now when i am on the highway at about 100Km's its at 1200* to 1250* and when i go to WOT it hovers between 1100* to 1200* (it was about 60*F out if that makes any difference) Does this sound like its running at a good temp? My plugs are a nice brown/tan colour.


    Heres the mods that are done to my motor in my Rampage.

    86 T1 Log motor:
    -Fully rebuilt motor with T2 rods (5000KMs on it)
    -K&N cone filter
    -MP logic module
    -MP #803 injectors
    -88TBI cam
    -TU turbo w quick spool option
    -2 1/2" exhaust
    -New fuel pump, filter and lines
    -EGR valve removed (solenoid still plugged in so it doesnt pull a code)
    -Timing 10*
    -NTK 02 sensor
    -Fuel pressure set at 60PSI static

    Thanks, Randy

  2. #2
    Rhymes with tortoise. Turbo Mopar Staff cordes's Avatar
    Join Date
    Dec 2005
    Location
    Tuscola, IL
    Posts
    19,793

    Re: EGT reading..

    FP should be 55PSI static. If you are running stock boost, that is what I would lower it to. Your WOT EGTs are a little cool by most peoples standards. Most shoot for 1450ish. WOT.

    The rest is very normal.

  3. #3
    Hybrid booster Turbo Mopar Contributor Turbo_Rampage's Avatar
    Join Date
    Jan 2006
    Location
    Edmonton, Alberta, Canada
    Posts
    662

    Re: EGT reading..

    Quote Originally Posted by cordes
    FP should be 55PSI static. If you are running stock boost, that is what I would lower it to. Your WOT EGTs are a little cool by most peoples standards. Most shoot for 1450ish. WOT.

    The rest is very normal.
    Thanks for the reply! I think i will leave it at 60PSI static to be on the safe side. (i set the FP at 60PSI because it was running a bit lean before) It also still gets awesome gas milege, and pulls hard at WOT. I am running 11lbs boost, but when it gets over 10PSI in 5th gear at 120Kms it starts to creep up to 13lbs, and i dont want it to lean out. (stupid log intake) I am waiting for my AEM Wideband gauge to come in the mail. That should tell me a little more on whats going on in the air/fuel ratio,

    Thanks

Similar Threads

  1. OMG, my EGT went over 1900 degrees!
    By mock_glh in forum EFI Tuning
    Replies: 18
    Last Post: 02-19-2008, 04:19 AM
  2. A/F vs EGT.
    By contraption22 in forum EFI Tuning
    Replies: 3
    Last Post: 11-13-2006, 10:55 AM
  3. Effect of rich condition on EGT?
    By guyd_15 in forum Exhaust
    Replies: 14
    Last Post: 11-02-2006, 09:02 AM
  4. EGT probe (dilema? help)
    By TrrboJeep in forum Exhaust
    Replies: 29
    Last Post: 10-05-2006, 09:06 PM
  5. Air/fuel ratio reading..
    By Turbo_Rampage in forum "I need help!"
    Replies: 23
    Last Post: 05-03-2006, 07:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •